Phase Link Disruption

Incident Report for Mosaic

Resolved

This incident has been resolved.
Posted Sep 20, 2025 - 03:01 UTC

Monitoring

Phase links have been restored. We are monitoring the results.
Posted Sep 13, 2025 - 21:25 UTC

Identified

We have recently been made aware of an issue where certain linked projects have their phases unlinked silently. This caused discrepancies and inaccuracy in reports, as unlinked phases no longer receive updates from target integrations. We understand the inconvenience and frustration this may cause, and we sincerely apologize for any disruption this may have brought to your activities.

The root cause of this problem has been fixed. Our technical team is currently working on restoring the impacted links. There is no action needed on your side.

In the meantime, if you encounter any difficulties or need further assistance, please don't hesitate to reach out to our Support Team at support@mosaicapp.com.
Posted Sep 08, 2025 - 23:01 UTC
This incident affected: Integrations (Deltek Ajera Integration, Unanet A/E Integration) and Resource Planning Portal (Projects, Reports).