Important Notice: AWS Outages Potentially Affecting Mosaic

Incident Report for Mosaic

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:53 UTC

Update

Mosaic's Reporting space appears to be impacted by the outages on AWS.

The Mosaic team is continuing to monitor the system for interruptions relating to the AWS service outage.

If you require any assistance or have any questions, please feel free to reach out to our Support Team through the Mosaic application, or at support@mosaicapp.com. Your feedback and patience during this time are greatly appreciated.
Posted Oct 20, 2025 - 16:50 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:38 UTC

Monitoring

The Mosaic team is aware of the potential impacts of the service outage and are closely monitoring for resolution from AWS.
Posted Oct 20, 2025 - 13:00 UTC

Investigating

We want to inform you that there is an ongoing service outage reported on Amazon Web Services (AWS). Currently Mosaic is not encountering any issues relating to this outage, but may be affected while the AWS team works to resolve the service outage.

The Mosaic team is aware of the potential impacts of the service outage and are closely monitoring for resolution from AWS.

Additional details from the AWS team can be found here: https://health.aws.amazon.com/health/status

If you require any assistance or have any questions, please feel free to reach out to our Support Team through the Mosaic application, or at support@mosaicapp.com. Your feedback and patience during this time are greatly appreciated.
Posted Oct 20, 2025 - 13:00 UTC
This incident affected: AWS Dependencies (AWS ec2-us-east-1, AWS iam, AWS pinpoint-us-east-1, AWS rds-us-east-1, AWS route53, AWS eks-us-east-1, AWS sns-us-east-1, AWS sqs-us-east-1, AWS secretsmanager-us-east-1, AWS vpc-us-east-1, AWS vpc-ca-central-1, AWS rds-ca-central-1, AWS lambda-us-east-1) and Resource Planning Portal (Reports).